Кто-нибудь видел, предупреждение: target указывает SWIFT_VERSION = '2.3'

Я просто конвертировал один из моих проектов из Swift 2.3 в Swift 3, и eventhoug все компилируется отлично, и все, кажется, работает, я продолжаю получать следующее предупреждение …

warning: target указывает SWIFT_VERSION = '2.3', но он переопределяется TOOLCHAINS = 'com.apple.dt.toolchain.XcodeDefault'

Кто-нибудь видел это предупреждение?

Предупреждение: введите описание изображения здесь

Многие из нитей, которые я нашел / прочитал, предлагают изменить параметр Command Line Tools: вариант использования Xcode 8, но мой уже использует Xcode 8.1(8B62)

Настройки: введите описание изображения здесь

Любое предложение?

One Solution collect form web for “Кто-нибудь видел, предупреждение: target указывает SWIFT_VERSION = '2.3'”

Похоже, что некоторые из ваших зависимостей могут указывать swift 2.3. Поэтому вы предупреждаете, что это может вызвать проблемы в следующем предстоящем обновлении. Вы также должны проверить настройки для своего проекта и убедиться, что в настройках проекта используется « Use Legacy Swift Language Version' = NO .

  • Связывание графика Facebook в приложении iOS и веб-приложении
  • Автоматическое тестирование уведомлений с помощью XCTest
  • Уменьшите симулятор Xcode (Retina 4 inch)
  • Почему Xcode перестает давать текстовое предсказание?
  • не удается найти заголовки фреймворков ios в ответной библиотеке родных модулей
  • xcode 6.1 И 7 остановок, отображающих значения переменных во время отладки
  • AFNetworking не будет компилироваться
  • идентификаторForVendor и iOS6
  • Не удается добавить сборку для тестирования внутреннего тестера
  • webViewDelegate и функция
  • Просмотрите файлы, созданные на устройстве, приложением IOS, которое я разрабатываю, на рабочей станции?
  • Xcode 8 beta - Как вы изменяете размер всех контроллеров view в раскадровке?
  • PhoneC: Разработка iOS проста с помощью XCode, Swift3, UITableView, cocatouch, давайте создадим приложения для iPhone, iPad и Macbook.