AFNetworking, похоже, не совместим с WatchKit

У меня есть существующее приложение iOS, которое использует фреймворк, который использует некоторые CocoaPods. Я добавил целевое приложение WatchKit, а затем добавил фреймворк к «Встроенные бинарные файлы». На этом этапе все еще компилируется и запускается. Как только я импортирую что-либо из рамки в расширение WatchKit, я получаю сообщение об ошибке

Не удалось создать модуль «FrameworkName».

Когда я создаю, в одном из файлов фреймов появляется другая ошибка:

Файл AFNetworking / AFNetworking.h не найден.

2 Solutions collect form web for “AFNetworking, похоже, не совместим с WatchKit”

Версии AFNetworking до версии 2.6 не будут поддерживать WatchOS без изменений – см. Требования AFNetworking . Поскольку v2.6 был выпущен после публикации этого вопроса, это, по-видимому, является причиной проблем, которые вы испытывали.

pod init снова, чтобы CocoaPods генерировал новые цели для вашего Podfile .

Добавьте свои зависимости как к основному приложению, так и к вашему расширению в Podfile .

  • Правильный способ кешировать анимированное изображение в Apple Watch?
  • sendSynchronousRequest: urlrequest returnResponse: & responce error: & ошибка недоступна в WatchOS2
  • Запустить приложение «Просмотр» на средний экран
  • watchOS 2: настройка свойств на начальном интерфейсном контроллере
  • Ошибка пути передачи данных в коде Xcode
  • Многократный ограничитель количества SMS WatchKit
  • Как экспортировать общий контейнер приложения iOS с Xcode6.2?
  • Как получить уведомление в наборе расширения набора часов из приложения ios?
  • После добавления расширения watchkit для проекта ранее добавленные сторонние структуры больше не работают
  • Как правильно использовать «openParentApplication» и «handleWatchKitExtensionRequest», чтобы вызвать «reply ()»?
  • Почему метод «willActivate» в «WKInterfaceController» уже вызван для следующей страницы?
  • Interesting Posts
    PhoneC: Разработка iOS проста с помощью XCode, Swift3, UITableView, cocatouch, давайте создадим приложения для iPhone, iPad и Macbook.