Можно ли разработать iOS 6 с помощью XCode 5 на Mavericks (OS X 10.9)?

Этот вопрос устарел. Mavericks выпущен, и все отлично работает с Xcode 5 и iOS 6 на iPod 4-го поколения.


Я подумываю об обновлении моей OS X до Mavericks, но я все еще хочу продолжить разработку своего приложения для iOS. Я читал в Интернете, что Xcode 4.6.3 несовместим с Mavericks (OS X 10.9). Таким образом, это заставит меня использовать новый Xcode 5. Однако Xcode 5 поставляется вместе с новым iOS 7 SDK. Проблема в том, что у меня есть iPod 4-го поколения, который несовместим с iOS 7.

Итак, кто-нибудь пробовал это уже? Я думаю, что это должно быть возможно, потому что на WWDC 2013 Apple так гордилась тем, что более 90% клиентов работают с новейшей iOS, которая в настоящее время по-прежнему остается iOS 6. Но с выпуском iOS 7 они будут погубить этот факт, потому что iOS 7, похоже, не совместим с iPod 4th Gen. И многие люди владеют таким устройством.

Я что-то пропустил, или Apple пойдет не так?

5 Solutions collect form web for “Можно ли разработать iOS 6 с помощью XCode 5 на Mavericks (OS X 10.9)?”

Ага.

Я развертываю свое четвертое поколение с Xcode 5 на ML – не Mavericks, но должен быть таким же.

Обратите внимание, однако, что вы не сможете отправить в App Store из Xcode 5 до момента выпуска iOS 7.

Обратите внимание, что вы хотите установить Mavericks на отдельный раздел !!! Не делайте это единственной ОС на вашем компьютере, пока она не будет выпущена.

Вы можете установить Xcode 4 путем временного редактирования версии системы.

  1. перейти в / system / library / coreservices
  2. Найдите SystemVersion.plist и откройте его.
  3. Измените два нижних числа (10.9) на 10.8.4 и сохраните
  4. Установить Xcode 4
  5. Измените эти цифры на 10.9 и сохраните.

Сделано, теперь у вас Xcode 4 на 10.9 🙂

Удачи!

У меня также была такая же проблема, когда я обновил xcode 5, и удалил старый sdk. Но я взял копию старого SDK с другого компьютера и тот же, что вы можете скачать по следующей ссылке.

http://www.4shared.com/zip/NlPgsxz6/iPhoneOS61sdk.html
(www.4shared.com тестовая учетная запись test@yopmail.com/test)

Есть два способа работы.

1) Разархивируйте и вставьте эту папку в /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs и перезапустите xcode.

Но это может быть снова удалено Xcode, если вы обновите xcode.

2) Еще один способ – распаковать и вставить, где вы хотите, и перейти в /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDK и создать символическую ссылку здесь, чтобы SDK оставался таким же, даже если вы обновляете Xcode.

Другое изменение, которое я сделал, «Настройка сборки»> «Архитектура»> стандартное (не 64), так что перечислите все версии цели развертывания

Не нужно загружать zip, если вы хотите изменить цель развертывания.

Вот несколько скриншотов. введите описание изображения здесьвведите описание изображения здесь

Вы можете установить Xcode4 и Xcode5 в ту же систему Maverick. Просто скачайте Xcode 4 с https://developer.apple.com/downloads/ и перетащите Xcode.app на рабочий стол, переименуйте его в Xcode4.app и переместите в / Applications.

Готово!

Исправьте, измените цель развертывания и установите его на 6.1, даже im также работайте над OS X 10.9, но хотите использовать симулятор 6.1.3 с Xcode 5. Im немного путают, что OS X 10.9 будет поддерживать Simulator 6.1.3 с Xcode 5 или нет. Я хочу, чтобы Simulator 7.0 выглядел как фрейм iphone, когда он запускался, но ничего не происходит …

  • Автоматический макет сохраняет растяжение UIImageView
  • Обмен быстрым кодом и поддержание кода в одном месте
  • Cocoapods framework не может найти файл в другой структуре cocoapods
  • Как я помещаю пустоту (трясущий жест) внутри IBAction (кнопка)?
  • Фреймы по умолчанию отсутствуют в Xcode 6 beta
  • Использование символических точек останова для дочерних классов в Xcode?
  • Раскадровка -JPEG
  • Эффект Scratch Card в Swift 3
  • Xcode запускает сценарий фазы в неправильном кодировании Ruby
  • Интеграция OS X Server + GIT с ошибками SSH с ошибкой отказа от разрешения
  • вопрос с изображением UIButton в UITableCellView
  • PhoneC: Разработка iOS проста с помощью XCode, Swift3, UITableView, cocatouch, давайте создадим приложения для iPhone, iPad и Macbook.