Xcode 6.4 "Не удалось загрузить и установить iOS 8.3 симулятор"

Я пытался установить iOS-симуляторы 8.3 и 8.4 на Xcode 6.3.2 и 6.4 beta соответственно. В первом случае даже нет возможности загрузить этот симулятор, а в Xcode 6.4 он показывает ошибку «Не удалось загрузить и установить iOS 8.3 Simulator. Для установки пакетов требуется авторизация». Я искал в Интернете, но ничего не нашел, поэтому я пытаюсь переустановить Xcode с веб-сайта разработчика Apple, а также из магазина приложений без каких-либо изменений. Единственный симулятор, который я могу использовать, – 8.2. Я не могу установить какую-либо другую версию. Любая помощь могла бы быть полезна.

Это ошибка на Xcode 6.4 без дополнительной возможности iOS 8.4 Simulator Xcode 6.4 beta

Это параметры симулятора для загрузки, которые приводят к этой ошибке введите описание изображения здесь

Это мои варианты в Xcode 6.3.2 без опции для iOS 8.3 Xcode 6.3.2

Я нашел обходное решение на форумах Apple . Если вы запускаете Xcode, используя sudo симулятор загружает и устанавливает работу просто отлично:

 sudo /Applications/Xcode.app/Contents/MacOS/Xcode 

Примечание. После завершения загрузки и установки вы должны выйти из Xcode и запустить его в обычном режиме.

Время выполнения iOS 8.3 Simulator включено в Xcode 6.3 (поэтому он не предлагается в качестве дополнительной загрузки).

Как показано на рисунке, время выполнения iOS 8.3 Simulator должно быть загружено с Xcode 6.4. В диалоговом окне сообщается, что при попытке установить пакет возникла проблема с аутентификацией. При установке пакета необходимо предоставить учетные данные администратора.

Причина, по которой вы получаете свой «iPhone 6, работает под управлением iOS 8.2, которая ниже, чем имя -проекта – минимальная цель развертывания». ошибки – это то, что вы выбираете iPhone 6 с iOS 8.2, а не iPhone 6 с iOS 8.3.

Используйте «xcrun simctl create» или окно «Устройства Xcode» для создания необходимых вам устройств iOS 8.3.

Interesting Posts
Давайте будем гением компьютера.